<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" id="typepad-standard" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
        <!-- head-common-individual -->
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <meta name="generator" content="http://www.typepad.com/" />
    <script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#p
roperty=5bf30852b4a6560011bd9c8b&product=gdpr-compliance-tool"></script>

<!-- BEGIN SHAREAHOLIC CODE -->
<link rel='preload' href='//apps.shareaholic.com/assets/pub/shareaholic.js' as='script' />
<script type="text/javascript" data-cfasync="false" async src="//apps.shareaholic.com/assets/pub/shareaholic.js" data-shr-siteid="80e7684e893a19cec0b7fb59a50c0221"></script>
<!-- END SHAREAHOLIC CODE -->
        
        <meta name="description" content="There has been much GOP/conservative tongue wagging at the emergence of the &quot;new&quot; socialist contingent within the Democratic Party. Conservative media has been focusing its attention on the insufferable Alexandria Ocasio-Cortez, who is the obvious result of a complete absence of good parental role models and a failed education system...." />




        <link rel="stylesheet" href="https://www.triadconservative.com/styles.css?v=6" type="text/css" media="screen" />
        <link rel="stylesheet" href="https://static.typepad.com/.shared/themes/common/print.css" type="text/css" media="print" />


<link rel="stylesheet" href="https://static.typepad.com/.shared/css/featherlight-gallery.css">

        <link rel="alternate" type="application/atom+xml" title="Posts on 'Triad Conservative' (Atom)" href="https://www.triadconservative.com/atom.xml" />
        <link rel="alternate" type="application/rss+xml" title="Posts on 'Triad Conservative' (RSS 1.0)" href="https://www.triadconservative.com/index.rdf" />
        <link rel="alternate" type="application/rss+xml" title="Posts on 'Triad Conservative' (RSS 2.0)" href="https://www.triadconservative.com/rss.xml" />
        <script type="text/javascript">
                var TPApp = {};
                TPApp.app_uri = "https://www.typepad.com/";
        </script>
        <script type="text/javascript" src="https://static.typepad.com/.shared/js/yui/yahoo-dom-event.js,/js/app/thumbnail-gallery-min.js"></script>

<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-225723-36', 'auto', {'name': 'Typepad'}, {'allowLinker': true} );  // Separate tracker for Typepad.
ga('Typepad.require', 'linker');
ga('Typepad.linker:autoLink', ['none']);
ga('Typepad.set', 'dimension1', '6a00d8341d1c8253ef0192ab488f95970d');
ga('Typepad.set', 'dimension2', 'Individual');
ga('Typepad.send', 'pageview');
</script>



<meta property="og:title" content="The Democrats' &quot;New&quot; Godless, Socialist Direction: How Quickly We Forget" />
<meta property="og:site_name" content="Triad Conservative" />
<meta property="og:type" content="blog" />
<meta property="og:url" content="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget.html" />
<meta property="og:description" content="There has been much GOP/conservative tongue wagging at the emergence of the &quot;new&quot; socialist contingent within the Democratic Party. Conservative media has been focusing its attention on the insufferable Alexandria Ocasio-Cortez, who is the obvious result of a complete absence of good parental role models and a failed education system...." />
<meta property="fb:admins" content="" />



<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="">
<meta name="twitter:creator" content="">
<meta name="twitter:title" content="The Democrats' &quot;New&quot; Godless, Socialist Direction: How Quickly We Forget">
<meta name="twitter:description" content="There has been much GOP/conservative tongue wagging at the emergence of the &quot;new&quot; socialist contingent within the Democratic Party. Conservative media has been focusing its attention on the insufferable Alexandria Ocasio-Cortez, who is the obvious result of a complete absence of good parental role models and a failed education system....">



        <link rel="alternate" type="application/atom+xml" title="Comments on 'The Democrats' &quot;New&quot; Godless, Socialist Direction: How Quickly We Forget' (Atom)" href="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget/comments/atom.xml" />
        <link rel="alternate" type="application/rss+xml" title="Comments on 'The Democrats' &quot;New&quot; Godless, Socialist Direction: How Quickly We Forget' (RSS 2.0)" href="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget/comments/rss.xml" />
        <title>The Democrats' "New" Godless, Socialist Direction: How Quickly We Forget - Triad Conservative</title>
        <link rel="start" href="https://www.triadconservative.com/" title="Home" />
        <link rel="prev" href="https://www.triadconservative.com/2019/02/nullification-bill-for-homosexual-marriage-in-north-carolina-house.html?no_prefetch=1" title="Nullification Bill for Homosexual &quot;Marriage&quot; in North Carolina House" />

    <script src="//code.jquery.com/jquery-1.11.2.min.js"></script>
<meta property="og:title" content="The Democrats' &quot;New&quot; Godless, Socialist Direction: How Quickly We Forget" />
<meta property="og:site_name" content="Triad Conservative" />
<meta property="og:type" content="blog" />
<meta property="og:url" content="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget.html" />
<meta property="og:description" content="There has been much GOP/conservative tongue wagging at the emergence of the &quot;new&quot; socialist contingent within the Democratic Party. Conservative media has been focusing its attention on the insufferable Alexandria Ocasio-Cortez, who is the obvious result of a complete absence of good parental role models and a failed education system...." />
<meta property="fb:admins" content="" />

</head>



<body class="layout-three-column-right post">
<div id="fb-root"></div>
<script>
window.fbAsyncInit = function() {
    FB.init( { apiKey: 'a279adbe87e2b3c505e777af99a5260d', xfbml: true, version: 'v2.8' } );
};
( function() {
    var e = document.createElement( 'script' ); e.async = true;
    e.src = document.location.protocol + '//connect.facebook.net/en_US/sdk.js';
    document.getElementById( 'fb-root' ).appendChild( e );
} )();
</script>

	
	<div id="container">
		<div id="container-inner" class="pkg">
			


<a id="home"></a>
   

<!-- banner -->
<div id="banner">
	<div id="banner-inner" class="pkg">
		
		<h1 id="banner-header"><a href="https://www.triadconservative.com/" accesskey="1">Triad Conservative</a></h1>
		<h2 id="banner-description">
			
		</h2>
	</div>
</div>






			<div id="pagebody">
				<div id="pagebody-inner" class="pkg">
					<div id="alpha">
						<div id="alpha-inner" class="pkg">
							<!-- the plain version removes the extra jquery -->
<!-- content nav -->
<p class="content-nav">
	<a class="content-nav-prev" href="https://www.triadconservative.com/2019/02/nullification-bill-for-homosexual-marriage-in-north-carolina-house.html">&laquo; Nullification Bill for Homosexual &quot;Marriage&quot; in North Carolina House</a> |
	<a class="content-nav-main" href="https://www.triadconservative.com/">Main</a>
	
</p>
<script type="text/javascript">
   $(function(){
       var query = window.location.search.substring(1);
       if( query == "pintix=1" ) {
          var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','https://static.typepad.com/.shared//js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);
       }
   });
</script>
<!-- entry -->

	<h2 class="date-header">02/16/2019</h2>


<div class="entry-author-triad_conservative entry-type-post entry" id="entry-6a00d8341d1c8253ef022ad3e3206c200b">
   <div class="entry-inner">
			<h3 class="entry-header">The Democrats' "New" Godless, Socialist Direction: How Quickly We Forget</h3>
	



	<div class="entry-content">
		<div class="entry-body">
			<p>There has been much GOP/conservative tongue wagging at the emergence of the &quot;new&quot; socialist contingent within the Democratic Party. Conservative media has been focusing its attention on the insufferable Alexandria Ocasio-Cortez, who is the obvious result of a complete absence of good parental role models and a failed education system.</p>
<p>Here in the eastern Triad, it is very easy to forget that we have had our share of similar politicians.</p>
<p>We used to have two United States Congressmen-- Brad Miller and Mel Watt-- who routinely had voting records <em>to the left</em> of Bernie Sanders. And that was way back when few people knew anything about Bernie Sanders.</p>
<p>Watt got a promotion to an executive branch job; and has been recently <a href="https://www.washingtonpost.com/business/2019/02/15/ig-report-former-congressman-attempted-coerce-relationship-with-employee/?utm_term=.ee5c497a5384">cited by the Inspector General for sexual harassment</a>. Is anyone surprised?</p>
<p>These men used to be the object of considerable local political celebration; and were the toast of the regional mainstream media including the News and Record.</p>
<p>Another delightful example is Pricey Harrison, the career Raleigh politician who is militantly pro-abortion and anti-life. She was invited to the Rose Garden for the Obamacare signing ceremony. She has been a major mover of &quot;green&quot; legislation in the past which inherently represents governmental coercion. And she has <a href="https://firstinfreedomdaily.com/nc-democrats-filed-their-own-new-deal-wish-list/">recently co-sponsored legislation</a> that seeks a laundry list of democratic socialist objectives forced upon the private sector: a 15% minimum wage, gender equity pay, requiring employers to offer paid sick leave and family leave, and allowing collective bargaining for public sector employees.</p>
<p>And then there is Greensboro&#39;s sweet Alma Adams who has never seen an abortion she did not like. She scores <em>further left</em> than Bernie Sanders on both the Conservative Review and Heritage Action scorecards. Adams no longer represents the eastern Triad; but as in the case of Pricey, it has been rumored she does not truly reside within her district.</p>
<p>The above discussion does not even remotely consider all our democratic socialist state legislators and local elected officials. But it is quite clear that we have had numerous elected officials who make Ocasio-Cortez and Sanders seem fairly routine.</p>
		</div>
		

                        <!-- SIGNATURE -->
                        
                        
<div id="signature">
        <div id="signature-inner">
        <div class="shareaholic-canvas" data-app="share_buttons" data-app-id="28354573"></div>
        </div>
</div>


		
	</div>

	<div class="entry-footer">
			<p class="entry-footer-info">
				<span class="post-footers">Posted at 08:11 PM </span> <span class="separator">|</span> <a class="permalink" href="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget.html">Permalink</a>
			</p>
		
		<!-- technorati tags -->

    


		<!-- post footer links -->
	<p class="entry-footer-share entry-footer-share-buttons">
		<span class="entry-footer-links-reblog"><a href="#" class="share-link share-link-reblog" title="Grab this post for your own blog" onclick="b=document.body; TYPEPAD___bookmarklet_domain='https://www.typepad.com/'; TYPEPAD___reblog_entryxid='6a00d8341d1c8253ef022ad3e3206c200b'; TYPEPAD___is_reblog = 1; if (b &amp;&amp; !document.xmlVersion) { void ( z=document.createElement('script')); void(z.type='text/javascript'); void(z.src='https://static.typepad.com/.shared/js/qp/loader-combined-min.js'); void(b.appendChild(z));}else{}">Reblog
 (0)
</a>
</span> <span class="separator">|</span> <span class="entry-footer-links-facebook_like">
     
     <fb:like href="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget.html" layout="button_count" show_faces="false"></fb:like>
     
</span>
	</p>


	</div>
   </div>
</div>



        
        
        <a id="comments"></a>
	<div class="comments" id="all-comments">
		<h3 class="comments-header">Comments</h3>
					<div class="comments-info">
				<p><a href="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget/comments/atom.xml"><img src="https://static.typepad.com/.shared/images/feed.png" alt="Feed" width="10" height="10" /></a> You can follow this conversation by subscribing to the <a href="https://www.triadconservative.com/2019/02/the-democrats-new-godless-socialist-direction-how-quickly-we-forget/comments/atom.xml">comment feed</a> for this post.</p>
			</div>
		
		<div class="comments-content" id="comments-content">
                <!-- comment list -->

		</div>
        
	</div>
<script type="text/javascript">var c943723d42e77e9214eb884a1d898ea="</form>";</script>
<script type="text/javascript">var ffe51c373e0873b7778b6324a0b5533 = '<form id="comment-form" action="';</script>
<script type="text/javascript">var c943723d42e77e9214eb884a1d898za = '" method="post"><input type="hidden" name="entry_xid" id="comment-entry-xid" value="6a00d8341d1c8253ef022ad3e3206c200b" \/><input type="hidden" name="token" value="1550373675-5e18afa3d5d1e154e2d07ce55f32e9e815b60bee:04jcJ1lo3WidDgPo" \/>';</script>
<script type="text/javascript">var OOcd55d4dc47109d7b462b01c7dd4dab = "aHR0cHM6Ly93d3cudHJpYWRjb25zZXJ2YXRpdmUuY29tLy5zZXJ2aWNlcy9jb21tZW50cw";</script>
<script type="text/javascript">var bad4dd7c10b264b7d90174cd4d55dc00 = atob(OOcd55d4dc47109d7b462b01c7dd4dab);</script>

<!-- comment-form-atp -->

	
<div id="atp-comments">
    
        <div id="comment-preview" class="hiddenBox">
	<h3 id="header-verify-comment" class="comments-header font-entryheader  hiddenBox">Verify your Comment</h3>
    <h3 id="header-preview-comment" class="comments-header font-entryheader  hiddenBox">Previewing your Comment</h3>
	<div class="comments-content font-entrybody">
		<div class="comment">
			<div id="comment-preview-content" class="comment-content">
			</div>
			<p class="comment-footer">
				Posted by: 
				<span id="comment-preview-author"></span>&nbsp;|&nbsp;<span id="comment-preview-datetime"></span>
			</p>
		</div>
	</div>
</div>
<div id="comment-preview-confirmation" class="font-entrybody hiddenBox yellowBox">
    <p>This is only a preview. Your comment has not yet been posted.</p>
        <form id="comment-preview-form"
                method="post"
                onsubmit="atpComments.interceptPost(1); return false;">
                <input type="submit" class="form-control font-entrybody" name="post" id="comment-confirm-post" value="&nbsp;Post&nbsp;" onclick="atpComments.interceptPost(1); return false;"/>
                <input type="submit" class="form-control font-entrybody"  name="edit" id="comment-edit" value="&nbsp;&nbsp;Edit&nbsp;&nbsp;" onclick="atpComments.previewOnly(2); return false;"/>
        <span id="previewFormSpinner" class="hiddenBox"><img src="/.shared/images/spinner.gif" alt="Working..." /></span>
        </form>
</div>

<div id="comment-error" class="hiddenBox font-entrybody redBox">	    
   Your comment could not be posted. Error type: <span id="comment-error-msg"></span> 
</div>	
<div id="comment-complete" class="hiddenBox font-entrybody  redBox">
    Your comment has been saved. Comments are moderated and will not appear until approved by the author. <a href="javascript:void 0;" onclick="window.location.hash='#comment-form';window.location.reload(false)">Post another comment</a>
</div>	
<div id="comment-captcha" class="hiddenBox yellowBox font-entrybody">	
    <div id="captchaText">
	    <p id="captchaFailMsg" class="captchaErrorText hiddenBox">The letters and numbers you entered did not match the image. Please try again.</p>	    	        
	    <p>As a final step before posting your comment, enter the letters and numbers you see in the image below. This prevents automated programs from posting comments.</p>
	    <p><span id="comment-captcha-viewalt">Having trouble reading this image? <a href="#comment-captcha" onClick="atpComments.generateReCaptcha();">View an alternate.</a></span></p>
    </div>
    <form id="comment-captcha-form" 
		  method="post"
		  onsubmit="atpComments.submitWithReCaptcha(); return false;">
    <div id="recaptcha_content">
      <noscript>
        <iframe src="6Ldg1s4SAAAAAEvvZX2ILFkWp7KB-jjdL4v0JV2e" height="300" width="500" frameborder="0"></iframe><br />
        <textarea name="recaptcha_challenge_field" rows="3" cols="40"></textarea>
        <input type='hidden' name='recaptcha_response_field' value='manual_challenge' />
      </noscript>
    </div>
  <script type="text/javascript">
    $(document).ready(function() {
        Recaptcha.create("6Ldg1s4SAAAAAEvvZX2ILFkWp7KB-jjdL4v0JV2e",
                         "recaptcha_content", {
                             theme: "red",
                             callback: Recaptcha.focus_response_field
        });
    });
  </script>
        <p>
            <input type="submit" name="continue" id="captcha-continue" value="&nbsp;Continue&nbsp;" />
            <span id="captchaFormSpinner" class="commentSpinner hiddenBox"><img src="/.shared/images/spinner.gif" alt="Working..." /></span>
        </p>
    </form>
</div>

    
	<div id="primary-comment-form" class="comment-form">
	    
	    <script type="text/javascript">document.write(ffe51c373e0873b7778b6324a0b5533+bad4dd7c10b264b7d90174cd4d55dc00+c943723d42e77e9214eb884a1d898za);</script>
	    
    		<div class="comments-open">
    		<i class="fas fa-comment"></i><h2 class="comments-open-header font-entryheader" id="comment-title">Post a comment</h2>
    			<div id="comments-open-content" class="comments-open-content font-entrybody">
    									
    				    <p class="comments-open-moderated font-entrybody">
    						Comments are moderated, and will not appear until the author has approved them.
    					</p>
    				
				
    									
    					<div id="comments-open-login" style="display: none;">
                  <div class="login-list font-entrybody">
                      
                      <span class="first">Sign in with</span> <span class="typepad"><a href="https://www.typekey.com/t/typekey/login?v=1.0&t=c1e393d21c9b516bc826a133691a0cc14881dd65&lang=en_US&_return=https%3A%2F%2Fwww.triadconservative.com%2F2019%2F02%2Fthe-democrats-new-godless-socialist-direction-how-quickly-we-forget.html&_portal=typepad">Typepad</a></span> <span class="facebook"><a href="https://www.typekey.com/t/typekey/login?v=1.0&t=c1e393d21c9b516bc826a133691a0cc14881dd65&lang=en_US&_return=https%3A%2F%2Fwww.triadconservative.com%2F2019%2F02%2Fthe-democrats-new-godless-socialist-direction-how-quickly-we-forget.html&_portal=typepad&service=facebook">Facebook</a></span> <span class="twitter"><a href="https://www.typekey.com/t/typekey/login?v=1.0&t=c1e393d21c9b516bc826a133691a0cc14881dd65&lang=en_US&_return=https%3A%2F%2Fwww.triadconservative.com%2F2019%2F02%2Fthe-democrats-new-godless-socialist-direction-how-quickly-we-forget.html&_portal=typepad&service=twitter">Twitter</a></span><span class="googleplus"><a href="https://www.typekey.com/t/typekey/login?v=1.0&t=c1e393d21c9b516bc826a133691a0cc14881dd65&lang=en_US&_return=https%3A%2F%2Fwww.triadconservative.com%2F2019%2F02%2Fthe-democrats-new-godless-socialist-direction-how-quickly-we-forget.html&_portal=typepad&service=gplus">Google+</a></span><span>and <a href="https://www.typekey.com/t/typekey/login?v=1.0&t=c1e393d21c9b516bc826a133691a0cc14881dd65&lang=en_US&_return=https%3A%2F%2Fwww.triadconservative.com%2F2019%2F02%2Fthe-democrats-new-godless-socialist-direction-how-quickly-we-forget.html&_portal=typepad&service=openid">more...</a></span>
                      
                  </div>
                  <div class="clr"></div>
    					</div>
    					<div id="comments-open-logout" style="display: none;">
    						You are currently signed in as
    						<span id="commenter-name">(nobody)</span>.
    						<a href="https://www.triadconservative.com/.services/sitelogout?to=https%3A%2F%2Fwww.typekey.com%2Ft%2Ftypekey%2F%3F__mode%3Dlogout%26_return%3Dhttps%253A%252F%252Fwww.triadconservative.com%252F2019%252F02%252Fthe-democrats-new-godless-socialist-direction-how-quickly-we-forget.html">Sign Out</a>
    					</div>
    				
                    	<div id="comments-open-text" style="display:none;">
        					<textarea id="comment-text" name="text" rows="10" cols="30" onkeyup="atpComments.maxTextArea(this, 64000);" class="form-control"></textarea>
            				
            				<p class="comments-open-subtext font-entrybody">
            				    (You can use HTML tags like &lt;b&gt; &lt;i&gt; and &lt;ul&gt; to style your text. URLs automatically linked.)
            				</p>			
            				                    					
        				</div>
    				    <div id="comments-open-data" class="font-entrybody">
                            <p>Your Information</p>
                            <p>
                                (Name is required. Email address will not be displayed with the comment.)
                            
                            </p>
			    
    						<p>
    							<input id="comment-author" at:default="Name" name="author" size="30" value="Name" onfocus="if(this.value==this.getAttribute('at:default')) this.value='';"  onBlur="if(this.value=='') this.value=this.getAttribute('at:default');" class="grayText"/>
    							<label for="comment-author" id="comment-author-error" class="comment-error hiddenBox">Name is required to post a comment</label>
    						</p>
    						<p>
    							<input id="comment-email" at:default="Email Address" name="email" size="30" value="Email Address" onfocus="if(this.value==this.getAttribute('at:default')) this.value='';"  onBlur="if(this.value=='') this.value=this.getAttribute('at:default');" class="grayText"/>
    							<label for="comment-email" id="comment-email-error" class="comment-error hiddenBox">Please enter a valid email address</label>
    						</p>
    						<p>
    							<input id="comment-url" at:default="Web Site URL" name="url" size="30" value="Web Site URL" onfocus="if(this.value==this.getAttribute('at:default')) this.value='';"  onBlur="if(this.value=='') this.value=this.getAttribute('at:default');" class="grayText"/>
    							<label for="comment-url" id="comment-url-error" class="comment-error hiddenBox">Invalid URL</label>
    						</p>

    					</div>
    		    </div>
                <div id="comments-open-footer" class="comments-open-footer font-entrybody" style="display:none;">
    				<input type="submit" name="post" id="comment-post-button" value="&nbsp;Post&nbsp;" onclick="atpComments.interceptPost(1); return false;" disabled="true" class="form-control font-entrybody"/>
    				<input type="submit" name="preview" id="comment-preview-button" value="&nbsp;Preview&nbsp;" onclick="atpComments.previewOnly(1); return false;" disabled="true" class="form-control font-entrybody  preview-button"/>

    				<span id="commentEntryFormSpinner" class="commentSpinner hiddenBox"><img src="/.shared/images/spinner.gif" alt="Working..." /></span>
    			</div>
    		</div>
	    		
	    <script type="text/javascript">document.write(c943723d42e77e9214eb884a1d898ea);</script>
	    
	    <noscript>
		
		<p>This weblog only allows comments from registered users. To comment, please enable JavaScript so you can sign in.</p>
				
		
	    </noscript>
	</div>
</div>





    
    




						</div>
					</div>
					<div id="beta">
						<div id="beta-inner" class="pkg">
							
<!-- sidebar1 -->


<!-- list_inlcude.tt  -->
<div id="aggregators" class="module-typelist module">
<h2 class="module-header">Aggregators</h2>
	<div class="module-content">
		<ul class="module-list">
							<li class="module-list-item"><a href="http://ncnewsandviews.com/">NC News and Views</a><br /></li>
							<li class="module-list-item"><a href="https://triaggregator.blogspot.com/">Greensboro's Triaggregator</a><br /></li>
							<li class="module-list-item"><a href="http://greensboro101.com/category/opinion/">Greensboro 101</a><br /></li>
			
		</ul><!-- last /ul -->
	</div>
</div>
<!-- end list_include.tt -->


<div class="module-recent-comments module">
	<h2 class="module-header">Recent Comments</h2>
	<div class="module-content">
		<ul class="module-list">
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/trump-pro-life-message-very-good-but.html?cid=6a00d8341d1c8253ef022ad3e25c2d200b#comment-6a00d8341d1c8253ef022ad3e25c2d200b">Fred Gregory</a> on <a href="https://www.triadconservative.com/2019/02/trump-pro-life-message-very-good-but.html">Trump Pro-Life Message: Very Good, But...</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/north-carolina-a-leader-in-health-care-transformation-emperors-without-clothes.html?cid=6a00d8341d1c8253ef022ad39b7b9d200c#comment-6a00d8341d1c8253ef022ad39b7b9d200c">Triad Conservative</a> on <a href="https://www.triadconservative.com/2019/02/north-carolina-a-leader-in-health-care-transformation-emperors-without-clothes.html">North Carolina a Leader in "Health Care Transformation"</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/north-carolina-a-leader-in-health-care-transformation-emperors-without-clothes.html?cid=6a00d8341d1c8253ef022ad39b70ae200c#comment-6a00d8341d1c8253ef022ad39b70ae200c">Fred Gregory</a> on <a href="https://www.triadconservative.com/2019/02/north-carolina-a-leader-in-health-care-transformation-emperors-without-clothes.html">North Carolina a Leader in "Health Care Transformation"</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html?cid=6a00d8341d1c8253ef022ad3e0501f200b#comment-6a00d8341d1c8253ef022ad3e0501f200b">Triad Conservative</a> on <a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html">Trump SOTU: Some Pointed Words About Socialism</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html?cid=6a00d8341d1c8253ef022ad39a782e200c#comment-6a00d8341d1c8253ef022ad39a782e200c">Fred Gregory</a> on <a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html">Trump SOTU: Some Pointed Words About Socialism</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/what-the-lgbt-crowd-misbehaves.html?cid=6a00d8341d1c8253ef022ad39a771d200c#comment-6a00d8341d1c8253ef022ad39a771d200c">Fred Gregory</a> on <a href="https://www.triadconservative.com/2019/02/what-the-lgbt-crowd-misbehaves.html">What? The LGBT Crowd Misbehaves?</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html?cid=6a00d8341d1c8253ef022ad3e01876200b#comment-6a00d8341d1c8253ef022ad3e01876200b">Triad Conservative</a> on <a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html">Trump SOTU: Some Pointed Words About Socialism</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html?cid=6a00d8341d1c8253ef022ad3c0668a200d#comment-6a00d8341d1c8253ef022ad3c0668a200d">Fred Gregory</a> on <a href="https://www.triadconservative.com/2019/02/trump-sotu-some-pointed-words-about-socialism.html">Trump SOTU: Some Pointed Words About Socialism</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/local-manufacturer-fined-by-doj-for-preferentially-hiring-american-citizens.html?cid=6a00d8341d1c8253ef022ad3bf864b200d#comment-6a00d8341d1c8253ef022ad3bf864b200d">Triad Conservative</a> on <a href="https://www.triadconservative.com/2019/02/local-manufacturer-fined-by-doj-for-preferentially-hiring-american-citizens.html">Local Manufacturer Fined by DOJ For Preferentially Hiring American Citizens</a>
			</li>
			<li class="module-list-item">
				<a href="https://www.triadconservative.com/2019/02/local-manufacturer-fined-by-doj-for-preferentially-hiring-american-citizens.html?cid=6a00d8341d1c8253ef022ad3defe42200b#comment-6a00d8341d1c8253ef022ad3defe42200b">Fred Gregory</a> on <a href="https://www.triadconservative.com/2019/02/local-manufacturer-fined-by-doj-for-preferentially-hiring-american-citizens.html">Local Manufacturer Fined by DOJ For Preferentially Hiring American Citizens</a>
			</li>
		</ul>
	</div>
</div>
<!-- list_inlcude.tt  -->
<div id="websites_worth_visiting" class="module-typelist module">
<h2 class="module-header">Websites Worth Visiting</h2>
	<div class="module-content">
		<ul class="module-list">
							<li class="module-list-item"><a href="http://www.carolinajournal.com">Carolina Journal/ JLF</a></li>
							<li class="module-list-item"><a href="http://www.breitbart.com/">Breitbart</a></li>
							<li class="module-list-item"><a href="http://www.realclearpolitics.com">RealClearPolitics</a></li>
							<li class="module-list-item"><a href="http://www.rhinotimes.com">Rhino Times</a></li>
							<li class="module-list-item"><a href="http://www.i-italy.org/">i-Italy</a></li>
							<li class="module-list-item"><a href="http://www.silive.com/#/0">Staten Island Advance </a></li>
							<li class="module-list-item"><a href="http://www.thepublicdiscourse.com">The Public Discourse</a></li>
							<li class="module-list-item"><a href="http://www.conservativehq.com/">Conservative HQ</a></li>
							<li class="module-list-item"><a href="http://www.wnd.com/">WND</a></li>
							<li class="module-list-item"><a href="http://www.worldmag.com/">World Magazine</a></li>
							<li class="module-list-item"><a href="http://www.constitutionpartync.com/">Constitution Party NC</a></li>
							<li class="module-list-item"><a href="http://www.chroniclesmagazine.org/blogs/recent-posts/">Chronicles</a></li>
							<li class="module-list-item"><a href="https://ilregno2s.blogspot.com/">Il Regno</a></li>
							<li class="module-list-item"><a href="https://sports.yahoo.com/golf/">Yahoo Sports</a></li>
							<li class="module-list-item"><a href="http://triad-city-beat.com/">Triad City Beat</a></li>
							<li class="module-list-item"><a href="http://yesweekly.com/category/news/">Yes!Weekly</a></li>
							<li class="module-list-item"><a href="http://atlanta.braves.mlb.com/index.jsp?c_id=atl">Atlanta Braves</a></li>
							<li class="module-list-item"><a href="http://www.myfox8.com">WGHP</a></li>
							<li class="module-list-item"><a href="http://www.wral.com/news/state/nccapitol/">WRAL Capitol</a></li>
							<li class="module-list-item"><a href="http://www.bizjournals.com/triad/">Triad Business Journal</a></li>
							<li class="module-list-item"><a href="https://weather.com/weather/today/l/27410:4:US">Weather.com</a></li>
							<li class="module-list-item"><a href="http://www.aapsonline.org/">AAPS</a></li>
							<li class="module-list-item"><a href="http://www.constitutionparty.com/">Constitution Party USA</a></li>
							<li class="module-list-item"><a href="http://www.jbs.org/jbs-news">JBS</a></li>
							<li class="module-list-item"><a href="http://www.greensboro.com/">News and Record</a></li>
							<li class="module-list-item"><a href="https://www.conservativereview.com/articles">Conservative Review</a></li>
							<li class="module-list-item"><a href="http://www.touchstonemag.com/">Touchstone</a></li>
							<li class="module-list-item"><a href="http://www.theamericanview.com/">American View</a></li>
							<li class="module-list-item"><a href="http://www.oann.com/">One America News</a></li>
							<li class="module-list-item"><a href="https://www.youtube.com/user/WildBillforAmerica/videos">Wild Bill</a></li>
							<li class="module-list-item"><a href="https://www.nccivitas.org/category/articles/">Civitas</a></li>
							<li class="module-list-item"><a href="https://www.marketwatch.com/">MarketWatch</a></li>
							<li class="module-list-item"><a href="https://seekingalpha.com">Seeking Alpha</a></li>
							<li class="module-list-item"><a href="https://www.greensboro.com/calendar/">Go Triad</a></li>
			
		</ul><!-- last /ul -->
	</div>
</div>
<!-- end list_include.tt -->






						</div>
					</div>
					<div id="gamma">
						<div id="gamma-inner" class="pkg">
							
<!-- sidebar2 -->


<!-- about page link -->
<div class="module-about module">
	<h2 class="module-header"><a
		href="https://triadconservative.typepad.com/about.html">About</a></h2>
</div>
<div class="module-syndicate module">
	<div class="module-content">
	<a href="https://www.triadconservative.com/atom.xml"><i class="fas fa-rss"></i> Subscribe to this blog's feed</a>
	</div>
</div>
<!-- list_inlcude.tt  -->
<div id="blogs_fb_pages" class="module-typelist module">
<h2 class="module-header">Blogs/ FB pages</h2>
	<div class="module-content">
		<ul class="module-list">
							<li class="module-list-item"><a href="https://www.nationalreview.com/bench-memos/" >Bench Memos</a><br /></li>
							<li class="module-list-item"><a href="https://www.nccivitas.org/civitas-review/" >Civitas Review</a><br /></li>
							<li class="module-list-item"><a href="https://www.facebook.com/constitutionpartync/" >Constitution Party of NC FB</a><br /></li>
							<li class="module-list-item"><a href="http://dailyhaymaker.com/" >Daily Haymaker</a><br /></li>
							<li class="module-list-item"><a href="https://greensboroperformingarts.blogspot.com/" >Ez Greensboro</a><br /></li>
							<li class="module-list-item"><a href="http://www.frcblog.com/" >Family Research Council Blog</a><br /></li>
							<li class="module-list-item"><a href="https://firstinfreedomdaily.com/" >First in Freedom Daily</a><br /></li>
							<li class="module-list-item"><a href="https://www.facebook.com/groups/freespeechgreensboro/" >Free Speech Greensboro FB</a><br /></li>
							<li class="module-list-item"><a href="https://www.facebook.com/groups/489455471144650/" >Greater Greensboro Politics FB</a><br /></li>
							<li class="module-list-item"><a href="https://blogontherun.wordpress.com/" >Lex Alexander</a><br /></li>
							<li class="module-list-item"><a href="https://www.theoccidentalobserver.net/" >Occidental Observer</a><br /></li>
							<li class="module-list-item"><a href="https://christianactionleague.org/category/commentary/" >Rev. Mark Creech</a><br /></li>
							<li class="module-list-item"><a href="https://lockerroom.johnlocke.org/author/sam-hieb/" >Sam Hieb-- Locker Room</a><br /></li>
							<li class="module-list-item"><a href="https://www.newsobserver.com/news/politics-government/politics-columns-blogs/under-the-dome/" >Under the Dome</a><br /></li>
			
		</ul><!-- last /ul -->
	</div>
</div>
<!-- end list_include.tt -->

<!-- archives -->

	<div class="module-archives module">
		<h2 class="module-header"><a href="https://www.triadconservative.com/archives.html">Archives</a></h2>
		<div class="module-content">
			<ul class="module-list">
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2019/02/index.html">February 2019</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2019/01/index.html">January 2019</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/12/index.html">December 2018</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/11/index.html">November 2018</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/10/index.html">October 2018</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/09/index.html">September 2018</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/08/index.html">August 2018</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/07/index.html">July 2018</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/06/index.html">June 2018</a></li>
				
					
					<li class="module-list-item"><a href="https://www.triadconservative.com/2018/05/index.html">May 2018</a></li>
				
			</ul>
		</div>
	</div>

<!-- powered by -->
<div class="module-powered module">
        <div class="module-content">

                <a href="https://www.typepad.com/" title="Blog">Blog</a> powered by <a href="https://www.typepad.com/" title="TypePad">Typepad</a>

        </div>
</div>
<!-- custom_code.tt --><div class="module-custom_html module">
    <div class="module-content">
<div class="sharethis-inline-share-buttons"></div><script async src="https://platform-api.sharethis.com/js/sharethis.js#property=5bf208d8b4a6560011bd9b98&product="inline-share-buttons"></script>
    </div>
</div>
<!-- end custom_code.tt -->





						</div>
					</div>
				</div>
			</div>
			



		</div>
	</div>
	







<script type="text/javascript">
<!--
var extra_happy = Math.floor(1000000000 * Math.random());
document.write('<img src="https://www.typepad.com/t/stats?blog_id=113341268772624141&amp;user_id=316100&amp;page=' + escape(location.href) + '&amp;referrer=' + escape(document.referrer) + '&amp;i=' + extra_happy + '" width="1" height="1" alt="" style="position: absolute; top: 0; left: 0;" />');
// -->
</script>




<script type="text/javascript" src="//www.google.com/recaptcha/api/js/recaptcha_ajax.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="/.shared/yui/2.9.0/yuiloader/yuiloader.js"></script>
<script type="text/javascript" src="/.shared/js/atpcomments.js?v=5"></script>

<!-- Begin disqus Tag -->

<!-- End disqus Tag -->
</body>
</html>

<!-- ph=1 -->
